Velleman VM111 (K8048), napájení 12V, nekorektní chování PIC

Prosím o radu:
Učím se programovat PIC a mám nový programátor VM111(K8048) s PIC 16F627.
Když svůj vlastní, jednoduchý program, nebo některý z příkladů z učebnic ve formátu hex chci nawritovat do PIC 16F627 přes PicProg2009 (viz screen), tak vidím že se to tam zapsalo (PicProg2009 to ohlásí a při přepnutí programátoru do Run změní činnost = jiné rozsvícení ledek) - jenže jinak než podle programu má. Pak to jde z PIC 16F627 zase vymazat, zase tam jde vložit něco jiného a zase to dělá něco jiného než má… a tak pořád dokola. Přitom vůbec nefungují vstupy (tlačítka na desce) a výstupy (ledky) dělají něco jiného než mají.
Nemá někdo podobnou zkušenost, nebo neporadí někdo co s tím?
Díky moc

obrazky.volne.eu/show.php/1804_pic.jpg.html

:arrow_right: administrator: přesunuto z "Microchip"

:arrow_right: administrator: přejmenováno z "Problém s VM111(K8048)"

:arrow_right: administrator: příspěvek byl upraven

:arrow_right: administrator: přiloženy externí soubory
velleman-vm111-k8048.jpg

a) Stavěl jsi programátor ze stavebnice, nebo jsi jej koupil sestavený?
Se stavebnicemi Velleman mám velmi špatné zkušenosti.
Programátor jsem stavěl a při oživení jsem zjistil, že plošný spoj má zkrat, který nebyl vidět ani s použitím silné lupy.
Pomohlo jen hrubé velmi hluboké proškrabání desky.

b) Programátor spolehlivě funguje jen při napájení 15V.
Potřebný zdroj jsem našel jen v PS electronic.

Je koupený.
S tím naapájením to asi bude ono. Pouzil jsem běžný adaptér 6-12V.
Dík za radu