Nastaveni fuses ATmega128: SUT_CKSEL: Ext. Crystal/Resonator

Zdravim,

potreboval bych poradit jak nastavit fuses pro ATmegu128, kdyz chci zadat SUT_CKSEL : Ext. Crystal/Resonator High Freq: Start up time :1K CK+64 ms, tak na me vyskoci okno, nemuzu najit pricinu. Krystal ma 16MHz. Dekuji za rady

i291.photobucket.com/albums/ll320/juraw/AVR.jpg

:arrow_right: administrator: přejmenováno z "Nastaveni fuses ATmega128"

:arrow_right: administrator: příspěvek byl upraven

:arrow_right: administrator: přiloženy externí soubory
AVR.jpg

Zdravím, nejsem si zcela jist jestli to pomůže, ale zkus v záložce main / ISP frequency změnit frekvenci.

Na jakou hodnotu? Zadal jsem 230,4kHz a chyba zase vyskocila… pri frekvenci 602.7Hz uz hlaska nevyskakuje, ale je to moc pomale

:arrow_right: administrator: příspěvek byl upraven
Předchozí příspěvky se necitují.

Tak ta frekvence musí být max. 1/4CLK nebo nižší. Zkoušej od té nejnižší co ti jede až dokud to zase nepojede a uvidíš.

Ahoj.
Kdyz to programujes tou nejnizzsi rychlosti tak se ti fuzes podari zmenit?
Pises ze je to moc pomale, ale naprogramovani fuzes je poslani cca 2 wordu, coz bys ani skoro nemel postrehnout. Dulezite vypisy jsou jestli se to povedlo nebo ne.
Pokud si prectes fuzes a je tam nastaveno Ext. Resonator a pouzivas krystal, je situace ze to muzes naprogramovat nejnizzsi rychlosti ale nemuzes vyssi docela divna.
Pokud se tak deje, muze to byt z nekolika duvodu.
Programator neni 100% kompatibilni se SW, nebo s HW.
v zapojeni uC k napajeni je neco shnileho
Zapojeni uC a programatoru je neco shnileho…
Kdyz tak to vyfot a nakresli jednoduche schema, napis, jaky programator pouzivas a jaky SW.
Mas to zapajene, nebo na nepajivem poli?
ATD…

Jde mi programovat od frekvence 28,8kHz do 230,4kHz, to ale pouze timto stylem : jedno funkcni naprogramovani, druhe naprogramovani = eror - nutne odpojit a zapojit usb (nebo ISP kabel) a zase jde jednou naprogramovat. Pouzivam BiProg upraveny na VUT, studentska verze, AVR studio 4,15. Fuzes mi jde nastavovat, ale nevim jak je nastavit. Fotky dodam zitra, je to vse osazene na desce

pri frekvenci 602.7Hz to vypise : ISP frequency must be 5kHz or above when programming EEPROM or FLASH

:arrow_right: administrator: příspěvek byl upraven
Předchozí příspěvky se necitují.

Ahoj.
Tak Biprog pouzivam taky, nevim, jak se lisi studentska verze od originalu ale predpokladam, ze jste jenom premapovali DPS aby to bylo snadneji vyrobitelne.
Mam AVRStudio 4.19 a tam se tato rychlost ani nevyskytuje, protoze je Studio dostupne po registraci doporucuji stahnout nejnovejsi verzi, ktera podporuje vice procesoru, je mozne, ze tam je pro tento procesor nejaky bug apod.
Dale autor biprogu pise na svych strankach, ze mu rychlost 603Hz nefunguje a planuje to zamenit za jinou napr 1.8MHz.
U ostatnich uC funguje programovani bezproblemu, nebo je nemas k dispozici?

Ahoj,
ano je predelana pouze deska a pridany prevodnik na usb, jine uC nemam k dispozici, novejsi verzy jsem zkousel (4,19), taky jsem mel problem

tady je osazeni desky :

i291.photobucket.com/albums/ll32 … bottom.png

nemohl by byt problem v paralelnim spojeni C9 a C10?

:arrow_right: administrator: přiloženy externí soubory
bottom.png

Ahoj,
Jak jiz psal DragonSoul, hodilo by se spise schema. Ty jsi sice poslal osazeni desky, ale z toho neni prilis patrne zapojeni jednotlivych periferii. takze by bodlo rozhodne schematko .
Navic z osazeni se mi zda, jako by byl pripojeny pin pro povoleni programovani (PEN) spolu s resetem nekam dal na nejaky konektor. Ale muzu se mylit. tim si nejsem stopro jisty.

P.S. C9 a C10 nejsou vubec zapojeny paralelne

Ahoj, diky za pripominku, zasilam kousek schematu, snad to bude citelne. Ano reset mam spojen s PENem a priveden na ISP konektor.

i291.photobucket.com/albums/ll320/juraw/sch.png

:arrow_right: administrator: přiloženy externí soubory
sch.png

Ahoj.
Ktery konektor pouzivas pro programovani?
ISP?
Pokud ano, tak je to nejak divne zapojene, protoze biprog komunikuje pres ISP s vodici MISO, MOSI, SCK a Reset.
Co tak vidim, tak napr. MISO neni vubec zapojene.
Pokud je v MEGA128 naprogramovany bootloader, a komunikuje se pres FT232 tak by se biprog vubec nemel pouzivat a melo by to jit pres obycejnou seriovku.

Neni to divne zapojene Atmega 128 pouziva pro programovani pres ISP ne signaly miso a mosi, tak jak to je vsude jinde, ale signaly TXD a RXD na PE0 a PE1. alepson nejak takhle jsou oznacene. … Sam nevim proc to tak je nelogicky, ale je to tak. Uz parkrat sem se pri tom pekne zapotil a zanadaval si, kdyz sem mel skoro celou desku navrzenou, a pote sem si uvedomil, ze pouziva jine piny.

:arrow_right: administrator: příspěvek byl upraven
Předchozí příspěvky se necitují.

Tak jsem si udelal resersi a vypadlo mi toto

To znamena, ze PEN pin by nemel byt pripojen,
Odstranit kompatabilitu s Mega103
MISO/MOSI nejsou pouziti k programovani Megy, ale zase z datasheetu vyplyva, ze kdyz pouzijes SPI programovani tak jsou MISO/MOSI pouzity, tak ted se v tom cert vyznej.
Ja teda nevim, treba pomuze nekdo jiny, s takovym velkym kladivem jsem si jeste nehral…

Edit2:
Takze k programovani jsou opravdu pouzity piny RXD, TXD, ale PEN by mel pres pull-up byt pripojeny k 5V. Zdroj zde avrfreaks.net/index.php?name=PNphpBB2&file=printview&t=57226&start=0

To uz si moc nevzpominam, jak je to s tim pinem PEN, ale mam takovy pocit ze se pise v datasheetu, ze je vnitrne nastaven pull up rezistorem. Pred programovanim sem ho shodil jumperem k zemi, a pote spustil napajeni a programoval sem, pres piny RXD a TXD.

Bylo by vhodne kdyby autor sdelil, zda je to jeho navrh, coby prototyp, nebo je primo tato deska odzkousena nekym jinym, nebo s nejakym jinym programatorem. Napada me, zda-li neni zakopany pes v tom spojeni PEN s RESETEM.

Neni nejaka moznost vyzkouset postup odpojit RESET od PENu a PEN hodit primo k zemi. treba pres nejaky odpor …???

Mozne by bylo, ze zustava PEN po naprogramovani nejakym zpusobem nabit na VCC . a tento pin se “vybije” az pri odpojeni obvodu od napajeni. napr. nejakou kapacitou z blizkosti napajeciho vodice, nedokonale zapajeni desky. dodana kapacita pomoci nejakeho nam skryteho kondenzatoru apd. …?

PEN s RESETEM mam spojeny pod mikroprocesorem, takze s tim nemuzu laborovat. Je to prototyp, ale u zapojeni PENu s RESETEM jsem vychazel z jineho zapojeni. V datasheetu pisou: PEN is a programming enable pin for the SPI Serial Programming mode, and is internally pulled
high . By holding this pin low during a Power-on Reset, the device will enter the SPI Serial Programming
mode. PEN has no function during normal operation.

Zkusil jsem merit napeti na PENu pred a po naprogramovani a vzdy tam byla nula

tak jsem nadzvedl nozicku PEN a problemy konecne zmizely