Attiny25-avrdude-problém

Zdravím,
potřeboval bych poradit. Mám projekt, kam jsem si navrhnul malé MCU Attiny25 a mam problém s nahráním hexu do MCU. Stáhl jsem si Microchip (Atmel) studio, nastavil vše tak jak má být, používám USBasp programátor, ale Atmel studio mi přesto píše tyto hlášky:

avrdude.exe: warning: cannot set sck period. please check for usbasp firmware update.
avrdude.exe: error: program enable: target doesn’t answer. 1
avrdude.exe: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

Včera jsem dvě hoginy googli po netu a nenašel nic kloudného. Pinout mám dobře u toho USBasp V2.0. Poradíte mi někdo jak ty hlášky eliminovat a rozjet programování?
Mockrát děkuji!

Máš tam krystal?

A jinak, já si s tím studiem hrál taky nedávno a je to pro mě katastofa a přešel jsem na arduino, tam mi u Attiny85 USBasp funguje normálně, akorát při prvním programování jsem musel dát krystal.

Mám, ale je to tragédie. Přehrával jsem z nouze i firmware toho shitu z číny a podělalo se to komplet. Tak te´d vybírám profesionální programátor, měl jsem pickit, ale já sem si ho odpálil vlastní blbostí. takže hledám něco co rozběhnu pod tím atmel studiem a nebude mne to stát fůru peněz.

To jsem ti zapomněl napsat, ať to nepřehráváš, není to třeba, pokud nemáš vyloženě jedny z prvních kousků USBasp. Já ho mám taky z Číny a bez problémů. Ale pod arduinem, pod studiem mi to nešlo, to ho ani nenašlo. Si zkus naistalovat arduino ide a zkus to pod ním.

EDIT: Když už si ho zmrtvil, tak arduino ide je zbytečné.
Mám toto
_vyr_1020_Snímek-obrazovky-2019-07-24-v-9-49-50

Jo, díky. Mám podobný, 2ks, mne ho to pod Atmel studiem našlo, nastavil jsem ho podle tutoriálu, ale hlásil mi právě tu chybu co jsem psal v prvním příspěvku, pak jsem ho zkoušel rozchodit i pod Arduino IDE a hlásil mi ty samé chyby. Tak jsem přehrál firmware a tím jsem oba dva poslal do pekla, nereagují. Takže já hledám něco co je profesionálního, ale za rozumnou cenu.

avrdude.exe: initialization failed, rc=-1 to znamená, že nekomunikuje s čipem, ale soft ho našel. Buď to máš blbě zapojené, mosi, miso, sck, reset, vcc, gnd, clock(krystal) a nebo, na těch pinech nesmí nic blokovat komunikaci. Zkoušel jsi to na nepájivém poli, nebo to máš už v “něčem”? Vím že v zapojeném stavu to programovat nejde.

A za těch cca 50,- Kč, co mě stál, s ním nemám problém, ale attinyxx musím mít v patici, když ho chci v konstrukci přehrát, aby šel dát do pole bez okolního “smetí”.

Vím, zkušel jsem rlzné pinouty a hlásilo to furt tu samou chybu. No, jsem oldschooler, takže si napřed sestavím obvod na nepájivém poli jak pro ana tak digi elektroniku.
Ale víš jak to dopadlo? Koupil jsem Asix presto, sice mne to nas…o ta cena, ale je to pro mne řešení na doufám, hodně let.
takže ještě jednou děkuji za ochotu věc řešit! :slight_smile: