Programování ATmega16, program. STK200 ISP dongle nefunguje

cau vsichni,
potreboval bych poradit s programovanim Atmega16 pres ISP , stale ji to nechce najit, programuju pres tohle pldaniels.com/flying/stk200-simple.png s atmega8 je vse v poradku ale kdyz to pripojim k atmega16 vubec ji to nenajde:( mam nekde noco blbe nastavenyho? nebo byste mi mohli pripadne poslat schema zapojeni primo s atmega16? diky moc…PS:potrebuju poradit konkretne s timto nebo trochu upravenym programatorem nechci tady rozvijet diskusi zda neni lepsi koupit hotovy programator…

:arrow_right: administrator: přesunuto z "ARM"

:arrow_right: administrator: přejmenováno z "programovani atmega16 pres ISP - zacatecnik"

:arrow_right: administrator: příspěvek byl upraven

:arrow_right: administrator: přiloženy externí soubory
stk200-isp-dongle-simple.png

Stáhni si radši PONYPROG ,možná budeš muset přepájet pár drátků na Canonu ale Mega 16 (a mnoho dalších) naprogramuješ spolehlivě a postav si trochu lepší programátor- schema tamtéž.

ahoj ja sem si postavil taky tenhle programator jen misto 4 rezistoru jsem pouzil 2 a to pouze na SCK a MOSI o hodnote 1k a funguje mi bez problemu, programuju to pomoci WinAvr a docela se da. Jestli chces tak ti pak k tomu muzu poslat i makefile, bez toho mi to taky chvili blbnulo.

Zdravim
Pokud ti to funguje s ATmega8 a nefunguje s ATmega16, zkusil bych overit zda jsou zapojene kabely k uC spravne, hlavne napajeni. Jinak se pouzivaji stejne signaly Miso, MOSI, SCK a RESET.
Je nutne dbat, aby byl programator uzemneny, VCC vlastne vubec nevyuzijes…

Pro administratora: Toto tema se tyka AVR, tak prosim o presun do spravneho tematu

no jeste jestli delas v winAvr tak myslim musis spustit soubor install_giveio.bat v adresari winavr/bin pak zkus program znovu nahrat do MCU