Nemuzu rozjet HCF4017BE

Zdravim vsechny kdo tady uspesne radi.
Chtel jsem si udelat jednoduche prepinani LED diod pomoci tohoto countru, myslim ze jsem vse zapojil spravne ale stejne nefunguje. Pro jistotu prikladam schema zapojeni. Neni tam uvedeno napajeni CMOS, 5V mam na pinu 16 a GND na pinu 8.
Led dioda na Portu 0 sviti neustale, coz je dle meho v poradku, ale pri stlacovani tlacitka se nic nedeje. Mam to umisteno na nepajivem poli.
Muzete pomoct vyresit?

:arrow_right: administrator: přesunuto z "Elektronika s mikrokontroléry, procesory"
schema2.png

z hladiska toho ze je to cmos…ta knedochadza k zmene log hodnoty na vstupe… daj za tlacitko odpor caa (neviem hodnotu R4?)10-100K na zem a bude to chodit alebo daj tlacidlo smerom na zem tj + cez odpor priamo do IO a vstup IO cez tlacidlo na zem…

Cau, nak sem se nedohledal v DS jestly na vstupu SCL je nakej pull xx,takze dal bych tam skusil dat pull down at sou ty urovne jasny, a pin 13 pripojit na L, v DS na casovym diagramu pokud je 13 v H je aktualni vystup drzen neustale v H …

*heh pozde *

Dekuji. Mezi tlacitko a IO 14 pin jsem dal 22K odpor smerem na zem, pin 13 jsem propojil na zem ale stale zadna reakce, LED na pinu 0 vytrvale sviti…

Tak jsem trosku postoupil, jeste jsem odpojil RESET pripojil pres odpor na zem a kondenzator paralelne k tlacitku a ted to funguje tak, ze port 0 se rozsviti od resetu po kazdych 10-ti zmacknuti, ale ostatni porty se nerozsviti… Zvlastni

EDIT: Diky moc, vse uz funguje jak ma, druha LED se nerosvitila protoze byla rozbita a 3 mela spatny kontakt na nepajivem poli…